Board index Peugeot RCZ Newbies Hello

Hello

Introduce yourself to the forum here. What do you drive and what have you ordered?

Post Sun Jul 01, 2018 10:00 am
James216 Newbie
Newbie

Posts: 1
Kudos: 0
Hi all,
My name is James I have a RCZ 2.litre diesel :greetings-wavingblue:
Here's a question I have oil level sensor read out has stopped working changed the sensor still no joy it should read oil ok when ignition is turned on but now I just have a couple of dashes it seems that there is no connection any ideas people :wtf:


Post Sun Jul 01, 2018 1:45 pm
DKZ5745 User avatar

Senior Member
Senior Member

Posts: 3768
Kudos: 1137
Location: Yorkshire
There is a slight possibility that the new sensor is also faulty, or you could try a BSI reset, it’s amazing what this can correct.

If you want to try a BSI reset :-

Put the driver’s window down, lift the bonnet and ensure all
equipment is switched off.
Ensure all doors are closed and remove key from the
ignition.
Wait for 3 minutes, disconnect the vehicle battery and wait
15 seconds.
Reconnect the vehicle battery, wait a further 10 seconds (do
not open doors.)
Switch on the side lights through the driver's window.
Switch on the ignition and check system’s functionality.
Hold lock button on key down for 10 seconds.
remove key open & close door test central locking system
Start the engine and complete the system’s check.
Failure to follow this procedure could result in incorrect operation of many
BSI related items.
Mk 2 GT200 Moroccan Red

Post Sun Jul 01, 2018 1:48 pm
DKZ5745 User avatar

Senior Member
Senior Member

Posts: 3768
Kudos: 1137
Location: Yorkshire
P.s.

:greetings-wavingblue: Welcome :text-welcomewave:

Now, let’s see some pics of your beautiful Z.....
Mk 2 GT200 Moroccan Red


Return to Newbies